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Chapter 1 Introduction 

1.1 Overview 
The purpose of this document is to serve as a user’s guide, tutorial, and general reference for the 
software application “Theodolite™”.  This application is intended to serve as a client application to 
be used with AuSIM’s GoldServ audio server application, such as can be found on an AuSIM 
GoldMiner™ system, or any other GoldServer system in AuSIM’s GoldSeries™ product line.  It is 
intended to allow an end user of a GoldServer system to set up a simple 3D acoustic space with 
one or more positioned sound sources, to initiate the AuSIM3D audio rendering process, and to 
end the rendering at the specified time. 

1.2 Background 
This application is similar in function and scope to the AuSIM3D client application “Spherical 
Renderer”, which has been included as a sample client application on some GoldMiner systems.  
However, Theodolite includes a graphical user interface that is used to modify the acoustic 
configuration file, whereas Spherical Renderer was a console application, and modification of the 
acoustic configuration file required the use of a text editor, as well as knowledge of the file format 
requirements.  Theodolite is designed to allow the end user to define and modify acoustic 
configuration files quickly and easily in an interactive editor, as well as to be able to start and stop 
rendering at any time to audition the current positioning of sounds. 

1.3 Setup 
To add sound sources to an acoustic ‘sphere’ configuration in Theodolite, either wave files or live 
input channels (or both) must be available on the AuSIM3D server computer system to which the 
Theodolite client has been connected.  If either of these exist, the built-in browser will allow them 
to be selected for inclusion in the acoustic configuration file.   

The main requirement for using Theodolite to audition acoustic environments that have been 
defined is a connection to an initialized GoldServer.  This connection can be by means of RS-
232, TCP, RPC, or USB connections.  For more information on establishing this connection, 
please see the GoldTools and/or the GoldServer user guides.  
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Chapter 2 Getting Started 
The Theodolite application can be launched by double-clicking on the Theodolite.exe icon or on a 
shortcut to this application.  This file is generally stored in the AuSIM3D\Client\App directory. 

2.1 Creating a File 
The first step in creating an acoustic configuration file is to select “New” from the “File” menu at 
the top of the Theodolite initial screen as shown in Figure 1. 

 
Figure 1 - Initial screen 

Selecting “New” will open the Source Parameters dialog box as shown in Figure 2.   

 
Figure 2 - Source Parameters window 

2.2 Specifying a Sound Source 
Using this Source Parameters window, a wave file or live input channel can be selected by 
double-clicking on the “Live inputs” or the “WAV” folder and selecting one of the files/channels 
displayed.  If the wavefile or line input signal is know, it can be simply typed in the ‘Name’ edit box 
rather than selected in the browse tree. 
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Next, to position this source, values for Azimuth, Elevation, and Range should be entered in the 
boxes with these labels, assuming the listener is located at the origin of the coordinate space.  
Leaving the Azimuth and Elevation values at their default values of zero will position the sound 
source directly in front of the listener, but a positive Range value should be entered to assure that 
the source will be located externally in front of the listener rather than inside his head, which 
could be result in an uncomfortably loud rendering of the sound source.   

The values for Gain and Channel can be left at their default values of zero; the effect of changing 
these will be discussed later.   

The Source Parameters window can now be closed by clicking the “OK” button.  A new window 
entitled “Theodolite1” will have appeared inside the previous window, which will now be entitled 
“Theodolite - Theodolite1” as in Figure 3 below: 

 
Figure 3 - Application Window and File Window 

The new, smaller window represents the acoustic configuration file that is being created, and 
displays the content of that file which will be saved.  In the example in Figure 3 above, a wave file 
named “Text.wav” has been attached to a sound source positioned directly in front of the listener 
at a distance of 15 units. 

2.3 Rendering Audio 
Now that a wave file and its position have been defined, is can be rendered in 3D.  Select the 
“Render” menu at the top of the application window and select “Play”, the first item on the menu.  
The wave file specified should now be audible through the system headphones, and it should 
sound as if it is positioned directly in front of you.   

If no audio is heard, make sure all the hardware is connected properly and a valid connection 
between the client and the GoldServ audio server has been established. 

2.4 Saving the File 
The information about the configuration of the acoustic space defined thus far can now be saved 
to a system file.   
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Select the “File” menu at the top of the application window, and then select “Save As…” from that 
menu with the mouse or pointing device.  This should open a dialog box like the one shown in 
Figure 4 below that will allow a system directory to be selected and a file name to be entered. 

 
Figure 4 - "Save As" Dialog Box for Saving File 

The default folder, folder contents, and directory structure displayed will depend on the setup and 
content of the client computer used and will probably not be the same as in the example above, 
although the dialog box itself should look familiar to an experienced MS Windows user. 

A default file name of “Theodolite1” will appear in the “File Name” box at the bottom of the 
window.  This name can be used to name the current file, but it might be more helpful for future 
retrieval if a more meaningful name is used, possibly incorporating a description of the wave 
file(s) involved, the name of the operator, the date and/or time of file creation, etc.   

A new folder location can be selected by navigating through the directory structure, starting with 
the “Save In:” box at the top of the window, or with one of the icons on the left, or, the default 
directory can be accepted for use. 

When the desired file name and directory have been specified, the “Save” button can be clicked 
with the mouse or pointing device to complete the file writing process and close the dialog box.  
The Theodolite application window can now be closed as well by selecting “Exit” from the “File" 
menu, or by clicking on the red “X” button in the upper right corner of the application window. 

This completes the basic process of creating and saving an acoustic configuration file using 
Theodolite.  For help in use of the more sophisticated features, please see the tutorial in Chapter 
3 and the reference material in Chapter 4. 
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Chapter 3 Tutorial 
The purpose of this chapter is to lead the user through the use of additional application features 
beyond those introduced in the previous Chapter, “Getting Started.  

Again, the Theodolite application can be launched by double-clicking on the Theodolite.exe icon 
or on a shortcut to this application. 

3.1 Opening a File 
Assuming an acoustic configuration file was created and saved via the process in the previous 
chapter, this same file will be opened again to begin this tutorial.  

The application window should open and appear as in Figure 1.  Select “Open” from the “File” 
menu at the top of the window, and a file-opening dialog box should appear as in Figure 5 below: 

 
Figure 5 - "Open" File Dialog Box 

Navigate through the directory structure to display the folder where the file was saved.  The file 
extension “.spr” should be visible appended to the file name selected.  Select this file with the 
mouse or pointing device to highlight it, and select the “Open” button or double-click on the name 
to open the file and close the dialog box.   

The file window should now appear inside the application window as in Figure 3. 

3.2 Adding a Sound Source 
An acoustic environment with only one sound source defined is not a very complex environment.  
In fact, one of the primary purposes of positioning sound sources in a 3D acoustic environment is 
to allow multiple sound sources to be displayed simultaneously with a spatial separation between 
them.  Therefore, the next step will be to add an additional source or two to the current acoustic 
space configuration.   

Select the “Edit” menu at the top of the application window, and then select “New Source…” from 
that menu with the mouse or pointing device.  This will open a Source Parameters dialog box like 
the one shown in Figure 2.   
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Using this Source Parameters dialog box, an additional wave file or live input channel can be 
selected by double-clicking on the “Live inputs” or the “WAV” folder and selecting one of the 
files/channels displayed.   

To position this source, values for Azimuth, Elevation, and Range should be entered in the boxes 
with these labels, assuming the listener is located at the origin of the coordinate space.  
Alternately, positional information can be entered in the form of rectangular (also known as 
“Cartesian”) coordinates by selecting the radio button next to the word “Rectangular” (above 
“Spherical”), and entering X, Y, and Z coordinates in the boxes with these labels.   

The units for X, Y, Z, and Range are inches by default, but they can be changed after this dialog 
box has been closed, so values can be entered assuming other units.  These values should also 
be chosen so as to position the sound source a sufficient distance from the ears and head to 
avoid an uncomfortably loud rendering. 

The value for Gain can also be set at this time by entering a value in the box labeled “Gain”.  
Leaving the Gain value at the default value of zero specifies that the wave file or live audio 
channel will be played at its default volume level without any amplification or attenuation 
performed by the system.  Entering a positive number into the “Gain” field will cause the 
rendering system to amplify the sound source by that many decibels, while entering a negative 
value will cause the system to attenuate the sound source by that many decibels. 

Since many wave files are recorded in stereo, two independent audio channels are contained in 
such wave files.  To select the left audio channel for auralization, leave “0” in the box labeled 
“Channel” in the lower left-hand corner; to select the right audio channel, enter a “1” in this box. 

The Source Parameters window can now be closed by clicking the “OK” button.  Two sources, 
one per row, should now be visible on the file window, with data displayed including name, 
position, gain, and channel, as in Figure 6 below. 

 
Figure 6 - Two Sound Sources Defined 

“New Source” can be selected from the “Edit” menu to add a new sound source to the acoustic 
space per the above procedure as many times as is desired; the only limitations are the CPU 
capacity of the audio server to render the selected number of sound sources, along with the 
capacity of the RAM to store wave files in active memory. 
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3.3 Editing a Sound Source 
Now that the Gain, Channel, and Rectangular Coordinates fields have been explained, or for any 
other reason, the user may wish to change the configuration of an existing sound source.  This 
can be accomplished by selecting the name of the wave file (or live channel) with the mouse or 
pointing device so that it is highlighted, and then selecting “Edit source” from the “Edit” menu at 
the top of the application window.   

This action will open the Source Parameters window again as shown in Figure 2.  The current 
values of Gain, Channel, Coordinates, and wave file or channel name will be displayed.  Any or 
all of these values can now be edited by typing new values into these fields.  When the new 
values are determined to be satisfactory, they can be accepted by clicking on the “OK” button.  
Alternately, if it is decided that it is preferable to keep the previously set values, the “Cancel” 
button can be selected with the mouse or pointing device, and all potential changes will be 
canceled.  In either case, the Source Parameters dialog box will be closed. 

Whenever any edits or changes to the acoustic configuration are made, it is prudent to save the 
file.  Selection of the “Save” menu item from the “File” menu saves the configuration change to 
the current file stored on disk. 

3.4 Deleting a Sound Source 
If the creation of sound sources has resulted in an excess of the number needed, any extra 
sound sources can be deleted from the acoustic configuration file.  This can be accomplished by 
selecting the name of the wave file (or live channel) with the mouse or pointing device so that it is 
highlighted, and then selecting “Delete” from the “Edit” menu at the top of the application window.  
The operator should make sure that the intended sound source is selected before clicking 
“Delete”, because there is no confirmation prompt to verify the sound source selected for 
removal.  On the other hand, it is relatively straightforward to restore an erroneously deleted 
source with the “New Source…” menu item as described in section 3.2 above. 

3.5 Changing Units 
The default unit of measurement assumed by Theodolite when linear distances are entered into 
the X, Y, Z, and Range fields is inches.  However, this can be changed with a menu selection.  
Select the menu “View” with the mouse or pointing device and hold the pointer over the “Units 
Interpretation” menu item to see the list of possible units: Inches, Feet, Millimeters, Centimeters, 
Meters.  The item with the check mark next to it is the unit currently used by the application to 
interpret entered values - at this point “Inches” should be found to be checked.  Select one of the 
other units with the mouse or pointing device, and notice that the distances displayed in the file 
window are NOT converted to the new unit; instead, Theodolite now assumes the current values 
and new ones entered are to be interpreted as feet or millimeters or centimeters or meters rather 
than inches. 
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3.6 Changing Coordinate Display 
Theodolite has the capability of displaying either spherical or rectangular (also known as 
Cartesian) coordinates.  Clicking on the “View” menu with the mouse or pointing device lists these 
options alphabetically.  The checkmark displayed next to “Spherical” shows that spherical 
coordinates are currently used to display sound source position.  The checkmarks next to 
“Spherical” and “Rectangular” may be toggled on and off by selecting them with the mouse or 
pointing device.  Selecting the “View” menu item “Rectangular” results in the display of both 
spherical and rectangular coordinates side-by-side as shown in Figure 7 below:  

 
Figure 7 - Rectangular and Spherical Coordinates Displayed Side-by-side 

The file and application windows may need to be resized for all of the data to be visible.  Window 
resizing is accomplished by clicking on the right-hand-side window border and holding the mouse 
or pointing device button down while dragging the border as far to the right as far as needed to 
see all the data. 

3.7 Rendering Audio 
When the all of the desired sound sources have been selected and placed at a specified position 
with a specified gain, the acoustic configuration is ready to be auditioned.  After making sure that 
the client system has a valid connection to an AuSIM GoldServ audio rendering server, select 
“Play” from the “Render” menu with the mouse or pointing device, and the wave files or live input 
channels selected should be audible over the system headphones at the appropriate locations in 
the acoustic space.  If the source positions do not seem to be as expected, double-check that the 
intended coordinate system and unit of measurement were used when entering the source spatial 
positions.   

All files or live inputs should begin rendering at exactly the same time, so that synchronously 
recorded tracks will be rendered in a synchronized manner. 

3.8 Muting Individual Sound Sources 
While one or more sound sources are being rendered, any or all of these sources can be muted 
on an individual basis by toggling off the check mark which by default appears next to the name 
of each sound source.  The check mark is toggled on or off via a click from the mouse or pointing 
device.  While a source is unchecked/muted, the pointer to the current position in the file will 
continue to progress at the normal rate, even though no audio from this source can be heard over 
the headphone.  As a result of this, when the source is checked/unmuted again, the file will start 
playing at a point past the point where it first became muted. 
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3.9 Enabling Disk Steaming 
By default, the disk streaming operation of Theodolite is not enabled.  To enable disk streaming, 
select the menu item “Disk Streaming Mode” from the “Render” menu with the mouse or the 
pointing device.  When disk streaming is enabled, this menu item will have a check mark next to it 
on the menu; alternately, when this mode is disabled, no check mark will appear.  The application 
can be toggled between the enabled and disabled modes by repeatedly selecting the “Disk 
Streaming Mode” menu item from the “Render” menu with the mouse or the pointing device as 
needed. 

3.10 Ending the Rendering 
By default, wave files will be launched in LOOP mode, meaning that when the end of a wave file 
is reached, it will start playing from the beginning again.  To disable LOOP mode so that files stop 
playing when they reach the end of the file, select the “Looping mode” menu item from the 
“Render” menu with the mouse or pointing device.  When the LOOP mode has successfully been 
disabled, the check mark next to the “Looping mode” menu item will have disappeared.  To re-
enable LOOP mode, select the “Looping mode” menu item again with the mouse or pointing 
device and verify that the checkmark next to it returns. 

If .WAV files or live input channels have played for a sufficient length of time to satisfy the 
operator, the audio can be stopped indefinitely by selecting “Stop” from the “Render” menu with 
the mouse or pointing device.  No more audio will be rendered until “Play” is selected again. 

3.11 Adding and Configuring Listeners and Head-Tracking 
The default operation of Theodolite is to initialize only one listener/binaural pair on the AuSIM 
GoldServ audio rendering server.  However, additional listeners can be added to the acoustic 
environment as needed.  This is accomplished with the selection of “Configure listeners…” from 
the “Render” menu to open the “Listeners Configuration” dialog box as shown in Figure 8 below: 

 
Figure 8 - Listeners Configuration Dialog Box 

To add a listener, click on the “Add…” button with the mouse or pointing device.  This will open 
the “Listener Properties” dialog box as shown in Figure 9 below: 

 
Figure 9 - Listener Properties Dialog Box 

A valid listener number, also sometimes referred to as a Head ID, can be assigned to the new 
listener from the “Head ID” drop-down box, which will list all of the as yet unused numbers which 
are available for selection.  This number can be selected from the drop-down list.   
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Also, any active tracking device sensors will have been detected by Theodolite and listed in the 
lower field labeled “Sensor”.  To assign a tracking sensor to a listener, the sensor of choice 
should be selected from the drop-down list with the mouse or pointing device.   

When the operator is satisfied with the choice of Head ID and Sensor, these choices can be 
accepted and the “Listener Properties” dialog box closed by clicking on the “OK” button.  To close 
the dialog box without establishing a new listener, the “Cancel” button or red “X” button should be 
clicked. 

To modify an existing Head ID or to change the sensor assigned to an existing listener, the “Edit” 
button can be clicked on the Listeners Configuration window as shown in Figure 8.  Like the 
“Add…” button, this will also open the “Listener Properties” dialog box as shown in Figure 9, in 
which the currently set Head ID and Sensor values will be displayed.  Either of these values can 
be updated by selecting a new value from one of the valid choices displayed in the drop-down list.  
When the Head ID and Sensor values are satisfactory, the selected choices can be accepted and 
the dialog box closed by clicking on the “OK” button.  To close the dialog box without changing 
the values that were set before the “Listener Properties” dialog box was opened, the “Cancel” 
button or red “X” button should be clicked. 

If the creation of additional listeners has resulted in an excess of the number needed, any extra 
listener definitions can be deleted from the acoustic configuration file.  This can be accomplished 
by selecting the extra Head ID on the “Listener Configuration” screen shown in Figure 8 with the 
mouse or pointing device so that it is highlighted, and then clicking the “Remove” button.  The 
operator should make sure that the intended listener is properly selected before clicking 
“Remove”, because there is no confirmation/prompt to verify the listener selected for removal.  On 
the other hand, it is relatively easy to add back an erroneously deleted listener with the “Add…” 
button as described above. 

When the operator is satisfied with the assignment of listeners to sensors, this configuration can 
be accepted and the “Listener Configuration” dialog box closed by clicking on the “OK” button.  To 
close the dialog box without changing any listener data, the “Cancel” button or red “X” button 
should be clicked. 

3.12 Arranging the File Windows 
Multiple acoustic configuration file windows can be open for concurrent editing in Theodolite.  
These windows can be created and managed using the “Window” menu items.  Selection of 
“Cascade” will arrange all file windows present in the application window in a cascading pattern 
so that only the top window is fully visible, but all windows are selectable.  Selection of “Tile” will 
arrange all file windows present in the application window in a tiled pattern so that all windows are 
visible simultaneously.  Selection of “Arrange Icons” will rearrange any minimized file windows 
into a linear pattern starting at the bottom-left corner of the application window. 

If some file windows become unselectable with the mouse or pointing device because they have 
been partially or wholly obscured by other file windows, any of them can be brought to the top 
and made the active window by selecting the window/file name from the bottom of the “Window” 
menu. 

3.13 Using Help 
Theodolite application information can be accessed from the “Help” menu.  The “About 
Theodolite…” menu item will open a window displaying the application version number and the 
copyright notice as shown in Figure 10 below: 

 
Figure 10 - About Theodolite 
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Chapter 4 Menu, ToolBar, and Display Reference 
The purpose of this chapter is to serve as a comprehensive reference guide to the various 
interface objects available in Theodolite.  The items described are grouped by type of object, and 
ordered by the order in which they occur on the Theodolite screen from left to right. 

4.1 Menu Selections 
The Theodolite application contains six menus arranged from left to right across the top of the 
application window (the outer-most window when there are more than one).  Upon initial launch of 
the application, only 3 of these menus are visible for selection, but the other three appear as soon 
as the first acoustic configuration file is created or opened.  Without a file window open, they 
would have no object upon which to operate. 

4.1.1 File 
The first menu from the left is the “File” menu.  Its menu items invoke common functions that are 
related to management of the acoustic configuration files used by Theodolite.  These functions 
include: 

• New – This menu item launches a “Source Parameters” dialog box that prompts for 
entry of sound-source information, and also creates a new window that displays and 
allows user interaction with the information in a new acoustic configuration file.  This 
menu item can also be invoked by simultaneously pressing the “Ctrl” and “N” keys. 

• Open – This menu item opens an existing acoustic configuration file that has the 
extension .SPR, creating a new window that displays and allows user interaction with 
the information in that file.  This menu item can also be invoked by simultaneously 
pressing the “Ctrl” and “O” keys. 

• Close – This menu item closes the active existing acoustic configuration window. 
• Save – This menu item saves updates made via the active acoustic configuration 

window to an existing file having an .SPR extension to which the window is linked.  
This menu item can also be invoked by simultaneously pressing the “Ctrl” and “S” 
keys. 

• Save As… – This menu item saves the active acoustic configuration window 
information to a file having an .SPR extension, prompting the user to enter a primary 
name for the file. 

• Exit – This menu item ends execution of the Theodolite application, closing the main 
window and all child windows. 

4.1.2 Edit 
The second menu from the left is the “Edit” menu.  Its menu items invoke functions that are 
related to editing the content of the acoustic configuration files used by Theodolite.  These 
functions include: 

• New Source – This menu item launches a “Source Parameters” dialog box that 
prompts for entry of sound-source information, including sound source name, 
position, gain, and channel number, and then uses the entered information to define 
a new sound source within the active acoustic configuration file.  This menu item can 
also be invoked by pressing the “Insert” key on the keyboard. 

• Edit Source – This menu item allows editing of information pertaining to the selected 
sound source within the active acoustic configuration file window, opening a “Source 
Parameters” dialog box that displays the existing sound source parameters and 
allows editing of those parameters.  These parameters include sound source name, 
position, gain, and channel number.  This menu item can also be invoked by 
simultaneously pressing the “Ctrl” and “E” keys. 

• Delete – This menu item deletes all information pertaining to the selected sound 
source, including sound source name, position, gain, and channel number.  There is 
no opportunity to confirm the deletion once this menu item is selected.  This menu 
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item can also be invoked by pressing the “Delete” key on the keyboard while a sound 
source is selected. 

• Units Interpretation – This menu item displays the possible units of measurement that 
can be used to interpret the input parameters pertaining to the position of each sound 
source in virtual acoustic space.  The unit with the check mark next to it represents 
the units in which linear distances are interpreted for each sound source, as well as 
the assumed unit of measurement for any new distance parameters entered by the 
operator.  The distance parameters to which these units apply for each sound source 
include X-coordinate, Y-coordinate, Z-coordinate, and Range.  The default active unit 
is “Inches” at the launch of the application, but it is changed to the most recently 
selected unit following user interaction. 

4.1.3 View 
The third menu from the left is the “View” menu.  Its menu items invoke functions that are related 
to viewing the content of the acoustic configuration files used by Theodolite.  These functions 
include: 

• Rectangular – Selecting this menu item when it is unchecked causes a checkmark to 
appear next to it, and the rectangular coordinates X, Y, and Z to be displayed in the 
file window for each defined sound source.  Selecting this item when it is already 
checked causes the checkmark to disappear, and the columns X, Y, and Z in the file 
window to be hidden.  The default state for the rectangular coordinates display is 
off/not displayed. 

• Spherical – Selecting this menu item when it is checked causes the checkmark next 
to it to disappear, and the spherical coordinates Azim, Elev, and Range to be hidden 
from view in the file window for each defined sound source.  Selecting this item when 
it is not checked causes a checkmark to appear next to it and the columns Azim, 
Elev, and Range in the file window to be displayed.  The default state for the 
spherical coordinates display is on/displayed. 

Note: these two sets of display columns are completely independent of each other, in that 
whether or not each is displayed has no effect on the other.  Possible configurations of the 
window include: only rectangular coordinates displayed, only spherical coordinates displayed, 
both rectangular and spherical coordinates are displayed, and neither rectangular nor spherical 
coordinates are displayed. 

4.1.4 Render 
The third menu from the left is the “Render” menu.  Its menu items invoke functions that are 
related to aurally rendering the content of the acoustic configuration files used by Theodolite.  
These functions include: 

• Play – This menu item begins the aural rendering of the wave files and live channels 
specified in the SPR file.  The sound sources are rendered by the GoldServ  
application at the location and gain specified in the SPR file.  This action can also be 
invoked by simultaneously pressing the “Ctrl” and “P” keys. 

• Stop – This menu item ends aural rendering of the wave files and live channels 
started with the Play menu item.  This action can also be invoked by simultaneously 
pressing the “Ctrl” and “T” keys. 

• Configure listener… – This menu item opens the “Listeners Configuration” dialog box.  
This window allows additional listeners to be added, removed, or assigned to tracking 
devices connected to the system.  It also allows the adjustment of a position update 
rate when reading data from a tracking device.  The default state is one listener with 
an ID of “0” not connected to a tracking device, and a position update rate of 20 Hz.  
This action can also be invoked by simultaneously pressing the “Ctrl” and “U” keys.  

• Disk streaming mode – Selecting this menu item when it is unchecked causes a 
checkmark to appear next to it, and the Disk Streaming Mode to be activated.  
Selecting this menu item when it is checked causes the checkmark next to it to 
disappear, and Disk Streaming Mode to be deactivated.  This action can also be 
invoked by simultaneously pressing the “Ctrl” and “D” keys.  
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• Looping mode - Selecting this menu item when it is unchecked causes a checkmark 
to appear next to it, and the Looping Mode to be activated.  In Looping Mode, wave 
files automatically start over at the beginning as soon as the end of the file is 
reached.  Selecting this menu item when it is checked causes the checkmark next to 
it to disappear, and Looping Mode to be deactivated.  With Looping Mode turned off, 
wave files stop playing when the end of the file is reached.  This action can also be 
invoked by simultaneously pressing the “Ctrl” and “L” keys.  

• Absolute delay mode – Selecting this menu item when it is unchecked causes a 
checkmark to appear next to it, and the Absolute Delay Mode to be activated.  
Selecting this menu item when it is checked causes the checkmark next to it to 
disappear, and Absolute Delay Mode to be deactivated.  This action can also be 
invoked by simultaneously pressing the “Ctrl” and “A” keys.  

4.1.5 Window 
The fifth menu from the left is the “Window” menu.  Its menu items invoke functions that are 
related to managing the Theodolite file display windows.  These functions include: 

• Cascade – This menu item arranges the open file windows in the Theodolite 
environment in a cascading pattern, so that the title bar and left-hand-side of each 
window is visible and selectable. 

• Tile – This menu item arranges the open file windows in the Theodolite environment 
in a tiled pattern, i.e. in a vertical column so that as much of each resized window as 
possible is fully visible and selectable. 

• Arrange Icons – This menu item only has an effect if one or more of the open file 
windows is minimized, in which case the minimized window icons are arranged in a 
horizontal row starting from the bottom left corner of the Theodolite application 
window. 

The remaining items in the “Windows” menu list the file windows that are currently open in the 
Theodolite workspace.  Selecting one of these menu items makes the selected window the 
currently active window, and brings it to the foreground if it is not already fully in front of other 
windows. 

4.1.6 Help 
The right-most menu is the “Help” menu.  It currently only has one selectable item: 

• About Theodolite… – This menu item opens a small banner window displaying the 
application version number and copyright notice.   

4.2 Toolbar Buttons 
The Theodolite application contains eight toolbar buttons arranged from left to right near the top 
of the application window (the outer-most window when there are more than one) just under the 
menu titles.  Upon initial launch of the application, only 5 of these menus are visible for selection, 
but the other three appear as soon as the first acoustic configuration file is created or opened.  
Without a file window open, these three buttons would have no object upon which to operate. 

4.2.1 New 
This button, marked with a document symbol, when clicked with the mouse or pointing device 
launches a “Source Parameters” dialog box that prompts for entry of sound-source information, 
and also creates a new window that displays and allows user interaction with the information in a 
new acoustic configuration file.  This action can also be invoked by selecting “New” from the “File” 
menu or by simultaneously pressing the “Ctrl” and “N” keys. 

4.2.2 Open 
This button, marked with a folder symbol, when clicked with the mouse or pointing device opens a 
window that allows the operator to browse to and open an existing acoustic configuration file that 
has the extension .SPR, creating a new file window that displays and allows user interaction with 
the information in that file.  Also, text files with TXT extensions can also be opened and displayed 
if they contain data in valid format, such as those which may have been created manually and 
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used with the Spherical Renderer application. This action can also be invoked by selecting 
“Open…” from the “File” menu or by simultaneously pressing the “Ctrl” and “O” keys. 

4.2.3 Save 
This button, marked with a floppy disc symbol, when clicked with the mouse or pointing device 
saves updates made via the active acoustic configuration file window to an existing acoustic 
configuration file with an .SPR extension to which the window is linked.  This action can also be 
invoked by selecting “Save” from the “File” menu or by simultaneously pressing the “Ctrl” and “S” 
keys. 

4.2.4 Play 
This button, marked with an arrow pointing to the right, when clicked with the mouse or pointing 
device begins the aural rendering of the wave files and live channels specified in the SPR file.  
The sound sources are rendered by the GoldServ application at the location and gain specified in 
the SPR file.  This action can also be invoked by selecting “Play” from the “Render” menu or by 
simultaneously pressing the “Ctrl” and “P” keys. 

4.2.5 Stop 
This button, marked with a small black square, when clicked with the mouse or pointing device 
ends aural rendering of the wave files and live channels started with the Play menu item.  It is 
only selectable when an SPR file is being rendered.  This action can also be invoked by selecting 
“Stop” from the “Render” menu or by simultaneously pressing the “Ctrl” and “T” keys. 

4.2.6 Headphone 
This button, marked with a symbol of a pair of headphones, when clicked with the mouse or 
pointing device opens the “Listeners Configuration” dialog box.  This window allows additional 
listeners to be added, removed, or assigned to tracking devices connected to the system.  It also 
allows the adjustment of a position update rate when reading data from a tracking device.  The 
default state is one listener with an ID of “0” not connected to a tracking device, and a position 
update rate of 20 Hz.  This action can also be invoked by selecting “Configure listeners…” from 
the “Render” menu or by simultaneously pressing the “Ctrl” and “U” keys. 

4.2.7 Disk 
This button, marked with a symbol of a compact disc, when clicked with the mouse or pointing 
device causes the Disk Streaming Mode to be activated.  Clicking on this button with the mouse 
or pointing device again while it is depressed causes the Disk Streaming Mode to be deactivated.  
This action can also be invoked by selecting “Disk streaming mode” from the “Render” menu or 
by simultaneously pressing the “Ctrl” and “D” keys. 

4.2.8 Loop 
This button, marked with a curved arrow pointing to its own tail, when clicked with the mouse or 
pointing device toggles the audio sources in the SPR file between Loop mode and No-Loop 
mode.  Its default state is depressed, representing Loop mode being activated.  In Looping Mode, 
wave files automatically start over at the beginning as soon as the end of the file is reached.  
Clicking on this button with the mouse or pointing device when it is depressed causes the 
Looping Mode to be deactivated.  With Looping Mode turned off, wave files stop playing when the 
end of the file is reached.  This toggle can also be invoked by selecting “Looping mode” from the 
“Render” menu or by simultaneously pressing the “Ctrl” and “L” keys. 

4.3 File Information Display 
Below the menus and toolbars, the Theodolite application window has a workspace that displays 
one or more windows that each represent the content of an acoustic configuration file.  The 
acoustic configuration file typically has an SPR extension, but text files with TXT extensions can 
also be opened and displayed by Theodolite if they contain data in valid format, such as those 
which may have been created manually and used with the Spherical Renderer application.   
Either the “New” or “Open” menu items or toolbar buttons can be used to create or open a 
window in this workspace, which will display the data from a new or exiting file.   
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4.3.1 The Configuration File Name Display 
At the top of each file window is a title bar displaying the name of the SPR or TXT file whose 
contents are being displayed.  If no file name has yet been designated, the title bar contains the 
name “Theodolite”, followed by a serial number that keeps track of how many windows for as yet 
unnamed files have been opened.   

4.3.2 The “Mute” Checkboxes 
The left-most column of data in each file window contains checkboxes that correspond to each of 
the independent sound sources that have been defined.  The top box corresponds to the first 
sound source, the box in the second row corresponds to the second sound source, and so on.  
By default, these boxes are checked, meaning the source will be audible when the “Play” menu 
item or toolbar button triggers the GoldServ rendering of the file.  Any box clicked with the mouse 
will toggle to become unchecked, after which the sound source will no longer be audible, but 
rather muted.  Additional clicks on the box will toggle the sound source back and forth between a 
muted and audible state.    

4.3.3 The Sound Source File Name Display 
The field to the immediate right of the checkboxes in each file window displays the name of the 
audio file or live input channel that is currently assigned to the sound source number 
corresponding to the row number.  In other words, the name on the top row corresponds to the 
first sound source, the name in the second row corresponds to the second sound source, and so 
on.  The audio file or live input channel assigned to a sound source can be modified by double-
clicking on the source name and browsing to a new audio file or live channel.  The same effect 
can be accomplished by highlighting the source row with a single mouse click and selecting “Edit 
Source…” from the “Edit” menu, or pressing the “CNTL” and “E” keys simultaneously. 

4.3.4 The Sound Source Coordinate Display 
The columns to the immediate right of the first column containing checkboxes and file/channel 
names contain the corresponding 3D location coordinates that have been assigned to each 
sound source for 3D rendering.  These columns will contain rectangular coordinates if 
“Rectangular” has been selected from the “View” menu, and spherical coordinates if “Spherical” 
has been selected from the “View” menu.  Both types of coordinates will be displayed if both 
types have been selected, but neither will be displayed if neither type has been selected.  The 
coordinate values can be modified by double-clicking on the source coordinates and editing the 
coordinate fields in the resulting dialog box.  The same effect can be accomplished by 
highlighting the source row with a single mouse click and selecting “Edit Source…” from the “Edit” 
menu, or pressing the “CNTL” and “E” keys simultaneously.  When modifying the coordinate 
values, the operator should be cognizant of the “Units Interpretation” setting on the “Edit” menu, 
as these are the units as which that the entered values will be interpreted. 

4.3.5 The Gain Display 
The column to the immediate right of the coordinate columns contains the gain value that has 
been set for each sound source for 3D rendering.  The default Gain value for each sound source 
is “0” until it is changed to a different value.  Any Gain value can be modified by double-clicking 
on the source information text and editing the Gain field in the resulting dialog box.  The same 
effect can be accomplished by highlighting the source row with a single mouse click and selecting 
“Edit Source…” from the “Edit” menu, or pressing the “CNTL” and “E” keys simultaneously. 

4.3.6 The Channel Display 
The column to the far right of the other columns contains the number of the wave file or live input 
channel value that has been assigned to the source.  Wave files are typically recorded in stereo 
and contain a right and left channel, whose numerical values are 0 and 1.  The default value of 
the Channel field is “0” until it is changed to a different value.  Any Channel value can be modified 
by double-clicking on the source information text and editing the Channel field in the resulting 
dialog box.  The same effect can be accomplished by highlighting the source row with a single 
mouse click and selecting “Edit Source…” from the “Edit” menu, or pressing the “CNTL” and “E” 
keys simultaneously. 


