Cisco 857 configurations - Static IP

This configuration is known working with c850-advsecurityk9-mz.123-8.YI1.bin. This configuration also relies on having the crypto featureset to make use of SSH console logins.

Help! I just need a working configuration now!
Copy the following out, replacing the bits in red with your own information. Click here if you want to see the explanations.
You should make sure that you SSH v2 switched on (ie have your done the generation stage already). If not, you can do this by doing the following from the command line:
conf term
ip domain-name your domain name
crypto key generate rsa usage-keys modulus 2048

This is the full working configuration (minus bits that are pertinent to my own connection):

version 12.3
no parser cache
no service pad
service tcp-keepalives-in
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service sequence-numbers
!
hostname name-of-your-device
!
boot-start-marker
boot-end-marker
!
logging userinfo
logging buffered 32000 informational
logging console informational
logging monitor informational
enable secret 5 password for your device
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login admin local
aaa session-id common
ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
!
!
no ip cef
ip inspect max-incomplete high 1100
ip inspect one-minute high 1100
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 tcp
ip tcp synwait-time 10
no ip bootp server
no ip domain lookup
ip domain name your domain name
ip name-server IP address of your ISP DNS server
ip name-server Second IP address of your ISP DNS server
ip ssh time-out 60
ip ssh authentication-retries 1
ip ssh version 2
login block-for 60 attempts 3 within 30
login on-failure log
login on-success log
no ftp-server write-enable
!
!
!
!
no crypto isakmp enable
no crypto isakmp ccm
!
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member1
!
interface FastEthernet0
no ip address
no cdp enable
!
interface FastEthernet1
no ip address
no cdp enable
!
interface FastEthernet2
no ip address
no cdp enable
!
interface FastEthernet3
no ip address
no cdp enable
!
interface Vlan1
ip address Your static IP address Your netmask
no ip proxy-arp
no ip mroute-cache
ntp broadcast
no cdp enable
hold-queue 100 out
!
interface Dialer0
ip unnumbered Vlan1
ip access-group 101 in
ip access-group 102 out
no ip redirects
no ip unreachables
no ip proxy-arp
ip inspect DEFAULT100 out
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ISP provided ADSL username
ppp chap password 7 ISP provided ADSL password
ppp pap sent-username ISP provided ADSL username password 7 ISP provided ADSL password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
!
!
!
access-list 101 permit any any
dialer-list 1 protocol ip permit
!
no cdp run
!
!
control-plane
!
banner motd ^C
This is machine name. Unauthorised access to this
machine is strictly prohibited. Please disconnect now unless
you have received prior authorisation for use. The systems
administrator is your name on Your phone number.
^C
!
line con 0
password 7 console password
login authentication admin
no modem enable
stopbits 1
line aux 0
line vty 0 4
exec-timeout 5 0
login authentication admin
transport input ssh
!
scheduler max-task-time 5000
ntp logging
ntp clock-period 17180042
ntp source Dialer0
ntp peer 193.0.0.228
ntp peer 130.88.200.98
ntp peer 158.152.1.76 prefer
end